วันนี้ผมเจอปัญหาว่าโปรแกรมที่ใช้งานผ่านเวปเรียกใช้งาน java ทั้งที่ติดตั้ง JRE แล้ว แต่ก็ยังไม่สามารถทำงานได้ ทั้ง IE และ Firefox มี error เดียวกันตามนี้

Java plugin cannot be started. Please ensure you have sun java 1.6 installed and java is enabled in browser settings.

Java plugin cannot be started

หลังจากค้นหากันอยู่นาน ก็พบว่า java ที่ลงนั้นเป็นเวอร์ชั่น 64 บิต แต่ว่า Web Browser ที่ใช้งานเป็น 32 บิต
วิธีแก้มี 2 อย่างครับ
1) เปลี่ยนไปใช้ web browser 64 บิต ตามรูป
ส่วนใครที่ใช้ Firefox ก็รอต่อไปครับ เพราะยังไม่มี Firefox เวอร์ชั่น 32 บิต ดังนั้นแนะนำให้ใช้วิธีที่ 2 แทน
IE 32-bit and 64-bit

2) ลง JRE 32 บิต และใช้งาน web browser 32 บิตตามเดิมครับ

โดยเราสามารถทดสอบได้ว่า java สามารถใช้งานได้ใน web browser หรือไม่โดยเข้าไปที่
http://java.com/en/download/testjava.jsp

Advertisements